Vulnerability · CVE-2026-61627
libass: Out-of-bounds read and write in wrap_lines_measure
Published Oct 30, 2026 · catalog updated Oct 31, 2026 · libass: Out-of-bounds read and
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-61627. EPSS is 0.15%. Act only if a listed version of libass: Out-of-bounds read and is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (libass: Out-of-bounds read and).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-61626 · High
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.15%
- Remediation
- Advisory link
- Affected products
- Debian:12 libass · Debian:13 libass · Debian:14 libass · vendor libass libass
libass is a portable subtitle renderer for the /SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in while rendering malicious content. In , a final line ending with a literal backslash-n sequence and otherwise consisting only of such sequences or spaces can remain after early trimming and make the line-measurement loops overshoot by one glyph. When the total text size exactly matches the allocated glyph-array capacity, the first loop reads an uninitialized 32-bit fixed-point value, although that value is not subsequently used. The second loop writes and beyond the array, zeroing the first and adding an attacker-controllable offset to the second. No actual exploitation beyond possible denial of service is known; broader exploitation is theoretical and constrained by the addresses, limited writes, and ASLR. This issue is fixed in version 0.17.5.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 libass0 → 1:0.17.1-1+deb12u1
- Debian:13 libass0 → 1:0.17.3-1+deb13u1
- Debian:14 libass0 → 1:0.17.5-1
- vendor libass libassversion unspecified
How to fix CVE-2026-61627
Upgrade
CVE-2026-61627 lists a fix boundary at 1:0.17.1-1+deb12u1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1:0.17.1-1+deb12u1 · 2 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-61627. EPSS is 0.15%. Act only if a listed version of libass: Out-of-bounds read and is installed.
Which versions are affected?
Compare what you have installed with 0 → 1:0.17.1-1+deb12u1, 0 → 1:0.17.3-1+deb13u1, 0 → 1:0.17.5-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-125: Out-of-bounds Read; CWE-787: Out-of-bounds Write. EPSS 0.15%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 30, 2026 · Trivy Vulnerability DB
Detected
Oct 30, 2026 · Trivy Vulnerability DB
Fix available
libass fixed in 1:0.17.1-1+deb12u1; libass fixed in 1:0.17.3-1+deb13u1; libass fixed in 1:0.17.5-1
Oct 30, 2026 · Trivy Vulnerability DB
Fix available
libass fixed in 1:0.17.1-1+deb12u1
Oct 30, 2026 · Trivy Vulnerability DB
Fix available
libass fixed in 1:0.17.3-1+deb13u1
Oct 30, 2026 · Trivy Vulnerability DB
Fix available
libass fixed in 1:0.17.5-1
Oct 30, 2026 · Trivy Vulnerability DB
Updated
The description or metadata changed.
Oct 31, 2026 · Trivy Vulnerability DB
Updated
libass is a portable subtitle renderer for the /SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in while rendering malicious content. In , a final line ending with a literal backslash-n sequence and otherwise consisting only of such sequences or spaces can remain after early trimming and make the line-measurement
Sources
- CVE.orgVulnerability recordCVE-2026-61627
libass is a portable subtitle renderer for the /SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in while rendering malicious content. In , a final line ending with a literal backslash-n sequence
cve.org - FIRST EPSSExploitation probabilityCVE-2026-61627
30-day exploitation probability 0.15%
first.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-61627
libass is a portable subtitle renderer for the /SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in while rendering malicious content. In , a final line ending with a literal backslash-n sequence
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 31, 2026
- Trivy Vulnerability DBOct 31, 2026
- CVE.orgOct 30, 2026