Security fix · CVE-2026-61846
Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage
Published Oct 29, 2026 · catalog updated Oct 31, 2026 · Red Hat Red Hat Enterprise Linux
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-61846. EPSS is 0.49%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-121995 · High
- CVE-2026-121996 · High
- CVE-2026-121997 · High
- CVE-2026-121994 · High
- CVE-2026-111253 · Medium
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.49%
- Remediation
- Version ranges on file
- Affected products
- Debian:12 ruby-crass · Debian:13 ruby-crass · Debian:14 ruby-crass · RubyGems crass · gem crass · rubygems crass
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises : stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 ruby-crass1.0.2-3, 1.0.6-1, 1.0.7-1
- Debian:13 ruby-crass1.0.6-1, 1.0.7-1, 1.0.8-1
- Debian:14 ruby-crass0 → 1.0.7-1
- RubyGems crass0 → 1.0.7
- gem crassversion unspecified
- rubygems crass< 1.0.7
How to fix CVE-2026-61846
Upgrade
CVE-2026-61846 lists a fix boundary at 1.0.7-1. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.0.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-61846. EPSS is 0.49%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Which versions are affected?
Compare what you have installed with 1.0.2-3, 1.0.6-1, 1.0.7-1, 1.0.6-1, 1.0.7-1, 1.0.8-1, 0 → 1.0.7-1, 0 → 1.0.7, < 1.0.7. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-400: Uncontrolled Resource Consumption; CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.49%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 29, 2026 · GitHub Advisory Database
Detected
### Impact Crass recursively parses CSS simple blocks and functions without a depth guard. An attacker-controlled value containing many deeply nested blocks can recurse until Ruby raises , or can cause excessive memory usage. ### Patches This is fixed in Crass 1.0.7, which adds a configurable depth limit with a conservative default. ### Workarounds Add handling around Crass calls in your applicati
Oct 29, 2026 · GitHub Advisory Database
Fix available
crass fixed in 1.0.7
Oct 29, 2026 · GitHub Advisory Database
Fix available
crass fixed in 1.0.7
Oct 29, 2026 · GitHub Advisory Database
Updated
### Impact Crass recursively parses CSS simple blocks and functions without a depth guard. An attacker-controlled value containing many deeply nested blocks can recurse until Ruby raises , or can cause excessive memory usage. ### Patches This is fixed in Crass 1.0.7, which adds a configurable depth limit with a conservative default. ### Workarounds Add handling around Crass calls in your applicati
Oct 31, 2026 · Trivy Vulnerability DB
Fix available
ruby-crass fixed in 1.0.7-1
Oct 31, 2026 · Trivy Vulnerability DB
Fix available
ruby-crass fixed in 1.0.7-1
Oct 31, 2026 · Trivy Vulnerability DB
Updated
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises : stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. Thi
Sources
- CVE.orgVulnerability recordCVE-2026-61846
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-61846
30-day exploitation probability 0.49%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-6jxj-px6v-747w
GitHub Advisory Database record mirrored by OSV.
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-61846
Crass recursively parses CSS simple blocks and functions without a depth guard. An attacker-controlled value containing many deeply nested blocks can recurse until Ruby raises SystemStackError: stack level too deep, or can cause excessive memory usage.
advisories.gitlab.com - OpenCVEVendor advisoryCVE-2026-61846
CVE-2026-61846 is named on the public OpenCVE page.
opencve.io - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-6jxj-px6v-747w
Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage
osv.dev - Red Hat Security DataVendor advisoryCVE-2026-61846
crass: crass: Denial of Service via deeply nested CSS structures
access.redhat.com - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-61846
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises : stack level t
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- OpenCVENov 5, 2026
- GitLab Advisory DatabaseNov 3, 2026
- GitHub Advisory DatabaseNov 2, 2026
- OpenSSF OSV / OSV ScannerNov 2, 2026
- Red Hat Security DataNov 1, 2026
- FIRST EPSSOct 31, 2026
- Trivy Vulnerability DBOct 31, 2026
- CVE.orgOct 30, 2026