Vulnerability · CVE-2026-6437
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated us…
Published Apr 17, 2026 · catalog updated Oct 20, 2026 · efs csi driver
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-6437. EPSS is 0.56%. Act only if a listed version of efs csi driver is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.56%
- Remediation
- Version ranges on file
- Affected products
- cpe amazon/efs csi driver
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe amazon/efs csi driver< 3.0.1
How to fix CVE-2026-6437
Upgrade
CVE-2026-6437 lists a fix boundary at 3.0.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.0.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-6437. EPSS is 0.56%. Act only if a listed version of efs csi driver is installed.
Which versions are affected?
Compare what you have installed with amazon/efs csi driver < 3.0.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-88. EPSS 0.56%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Apr 17, 2026 · NIST NVD
Detected
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Jun 17, 2026 · NIST NVD
Updated
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Oct 20, 2026 · NIST NVD
Updated
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Sources
- CVE.orgVulnerability recordCVE-2026-6437
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-6437
30-day exploitation probability 0.56%
first.org - NIST NVDVulnerability recordCVE-2026-6437
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 31, 2026
- NIST NVDOct 21, 2026
- CVE.orgOct 16, 2026