Vulnerability · CVE-2026-7210
and use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerabili…
Published May 11, 2026 · catalog updated Oct 2, 2026 · the affected product
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-7210. EPSS is 0.67%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-3087 · Medium
- CVE-2026-6019 · Low
- CVE-2026-4519 · High
- CVE-2026-4224 · Medium
- CVE-2026-3644 · Medium
- Severity
- Medium6.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.67%
- Remediation
- Version ranges on file
- Affected products
- cpe python/python
and use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe python/python3.15.0
- cpe python/python< 3.13.14
- cpe python/python< 3.14.6
How to fix CVE-2026-7210
Upgrade
CVE-2026-7210 lists a fix boundary at 3.13.14. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.13.14
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-7210. EPSS is 0.67%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with 3.15.0, < 3.13.14, < 3.14.6. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-331. EPSS 0.67%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
May 11, 2026 · NIST NVD
Detected
and use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Oct 2, 2026 · NIST NVD
Updated
and use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.
Sources
- CVE.orgVulnerability recordCVE-2026-7210
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-7210
30-day exploitation probability 0.67%
first.org - NIST NVDVulnerability recordCVE-2026-7210
and use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying thi
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- NIST NVDOct 21, 2026
- CVE.orgOct 16, 2026