Vulnerability · CVE-2026-75507
GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule
Published Oct 22, 2026 · catalog updated Oct 22, 2026 · Red Hat Red Hat Enterprise Linux
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-75507. EPSS is 0.60%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-123151 · High
- CVE-2026-121995 · High
- CVE-2026-121996 · High
- CVE-2026-121997 · High
- CVE-2026-121994 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.60%
- Remediation
- Version ranges on file
- Affected products
- PyPI graphql-core · package pip · pip graphql-core · pypi graphql-core
### Summary The validation rule can be driven into quadratic — and in the worst case — running time by a small, highly compressible query. A single 364 KB document can occupy one CPU core for over five minutes during *validation*, before any resolver runs. Because the rule is part of and therefore enabled by default, every GraphQL-core based server is affected at default settings. ### Details compares every pair of fields that share a response name and recurses into their sub-selections. The memoization added for CVE-2023-26144 ( ) is keyed by **named fragment** identity, so it does not cover this path: inline fragments are flattened into the parent selection set before the cache is consulted, and therefore every pair is re-compared from scratch at every nesting level. Repeating an inline fragment that selects the same response name at two nesting levels multiplies the two effects. There was no comparison budget and no validation timeout, so the rule ran to completion regardless of cost. The cost is incurred in the **validation phase**, which is what makes this hard to defend against from outside the library: query-depth limiters, complexity analyzers and cost estimators all operate on the parsed document *after* validation, and the malicious document is trivially shallow (depth 3, complexity 1). The payload is also one short string repeated many times, so it compresses to a few kilobytes and slips past body-size limits and WAF inspection that only see the compressed request. ### Proof of concept Measured on GraphQL-core 3.2.8 / CPython 3.12 / Linux x86_64: | n | m | query size | validation time | |---|---|---|---| | 20 | 20 | 7.6 KB | 0.16 s | | 50 | 50 | 46 KB | 5.2 s | | 100 | 100 | 182 KB | 81 s | | 200 | 100 | 364 KB | **319 s** | Doubling at fixed quadruples the time, as expected for a quadratic outer loop driving a quadratic inner walk. ### Impact Denial of service. One request pins one worker process for minutes; because CPython holds the GIL for this pure-C
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI graphql-core3.0.0 → 3.2.12
- PyPI graphql-core3.3.0a1 → 3.3.0rc1
- package pipversion unspecified
- pip graphql-core>= 3.0.0, < 3.2.12
- pip graphql-core>= 3.3.0a1, < 3.3.0rc1
- pypi graphql-coreversion unspecified
How to fix CVE-2026-75507
Upgrade
CVE-2026-75507 lists a fix boundary at 3.2.12. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.2.12
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-75507. EPSS is 0.60%. Act only if a listed version of Red Hat Red Hat Enterprise Linux is installed.
Which versions are affected?
Compare what you have installed with 3.0.0 → 3.2.12, 3.3.0a1 → 3.3.0rc1, >= 3.0.0, < 3.2.12, >= 3.3.0a1, < 3.3.0rc1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-400: Uncontrolled Resource Consumption; CWE-407; CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.60%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 22, 2026 · Red Hat Security Data
Detected
graphql-core: graphql-core: Denial of Service via nested inline fragments during query validation
Oct 22, 2026 · GitHub Advisory Database
Updated
### Summary The validation rule can be driven into quadratic — and in the worst case — running time by a small, highly compressible query. A single 364 KB document can occupy one CPU core for over five minutes during *validation*, before any resolver runs. Because the rule is part of and therefore enabled by default, every GraphQL-core based server is affected at default settings. ### Details comp
Oct 22, 2026 · PyPA Advisory Database
Fix available
graphql-core fixed in 3.2.12; graphql-core fixed in 3.3.0rc1
Oct 22, 2026 · PyPA Advisory Database
Fix available
graphql-core fixed in 3.2.12
Oct 22, 2026 · PyPA Advisory Database
Fix available
graphql-core fixed in 3.3.0rc1
Oct 22, 2026 · PyPA Advisory Database
Updated
### Summary The validation rule can be driven into quadratic — and in the worst case — running time by a small, highly compressible query. A single 364 KB document can occupy one CPU core for over five minutes during *validation*, before any resolver runs. Because the rule is part of and therefore enabled by default, every GraphQL-core based server is affected at default settings. ### Details comp
Sources
- CVE.orgVulnerability recordCVE-2026-75507
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-75507
30-day exploitation probability 0.60%
first.org - GitHub Advisory DatabasePackage advisoryGHSA-vj8h-fx38-h3vc
GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-75507
The OverlappingFieldsCanBeMerged validation rule can be driven into quadratic — and in the worst case O(n²·m²) — running time by a small, highly compressible query. A single 364 KB document can occupy one CPU core for over five minutes during validation, before any resolver runs. Because the rule is part of specified_rules and therefore enabled by default, every GraphQL-core based server is affect
advisories.gitlab.com - PyPA Advisory DatabasePackage advisoryGHSA-vj8h-fx38-h3vc
GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule
osv.dev - Red Hat Security DataVendor advisoryCVE-2026-75507
graphql-core: graphql-core: Denial of Service via nested inline fragments during query validation
access.redhat.com - Snyk Vulnerability DatabasePackage advisorySNYK-PYTHON-GRAPHQLCORE-21433568
Inefficient Algorithmic Complexity
security.snyk.io
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- Snyk Vulnerability DatabaseOct 25, 2026
- GitHub Advisory DatabaseOct 23, 2026
- PyPA Advisory DatabaseOct 23, 2026
- GitLab Advisory DatabaseOct 23, 2026
- Red Hat Security DataOct 23, 2026
- CVE.orgOct 23, 2026