Security fix · CVE-2026-77281
Caddy is an extensible server platform that uses TLS by default.
Published Sep 17, 2026 · catalog updated Oct 24, 2026 · Caddy is an extensible
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-77281. EPSS is 0.49%. Act only if a listed version of Caddy is an extensible is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Caddy is an extensible).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.49%
- Remediation
- Advisory link
- Affected products
- Debian:12 caddy · Debian:13 caddy · Debian:14 caddy
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 caddy0 → 2.6.2-5+deb12u1
- Debian:13 caddy2.11.2-1, 2.11.2-1~bpo13+1, 2.11.4-1
- Debian:14 caddy0 → 2.11.4-1
How to fix CVE-2026-77281
Upgrade
CVE-2026-77281 lists a fix boundary at 2.6.2-5+deb12u1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 2.6.2-5+deb12u1 · 4 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-77281. EPSS is 0.49%. Act only if a listed version of Caddy is an extensible is installed.
Which versions are affected?
Compare what you have installed with 0 → 2.6.2-5+deb12u1, 2.11.2-1, 2.11.2-1~bpo13+1, 2.11.4-1, 0 → 2.11.4-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.49%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 17, 2026 · OpenSSF OSV / OSV Scanner
Detected
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, a
Oct 24, 2026 · OpenSSF OSV / OSV Scanner
Fix available
caddy fixed in 2.6.2-5+deb12u1; caddy fixed in 2.11.4-1
Oct 24, 2026 · OpenSSF OSV / OSV Scanner
Fix available
caddy fixed in 2.6.2-5+deb12u1
Oct 24, 2026 · OpenSSF OSV / OSV Scanner
Fix available
caddy fixed in 2.11.4-1
Oct 24, 2026 · OpenSSF OSV / OSV Scanner
Updated
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, a
Sources
- CVE.orgVulnerability recordCVE-2026-77281
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-77281osv.dev
- Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-77281
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement b
osv.dev
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 24, 2026
- Trivy Vulnerability DBOct 24, 2026
- OpenSSF OSV / OSV ScannerOct 24, 2026