Vulnerability · CVE-2026-78675
GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include]
Published Aug 25, 2026 · catalog updated Oct 29, 2026 · GitPython before 3.1.59 fails
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-78675. EPSS is 0.18%. Act only if a listed version of GitPython before 3.1.59 fails is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (GitPython before 3.1.59 fails).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.18%
- Remediation
- Advisory link
- Affected products
- Debian:12 python-git · Debian:13 python-git · Debian:14 python-git
GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include] directives. Attackers can craft a malicious .gitmodules file with include directives pointing to sensitive files; when repo.submodules is accessed, GitConfigParser raises MissingSectionHeaderError embedding the target file's first line verbatim in the exception message.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 python-git3.1.30-1, 3.1.30-1+deb12u2, 3.1.36-1
- Debian:13 python-git0 → 3.1.44-1+deb13u1
- Debian:14 python-git0 → 3.1.61-1
How to fix CVE-2026-78675
Upgrade
CVE-2026-78675 lists a fix boundary at 3.1.44-1+deb13u1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 3.1.44-1+deb13u1 · 4 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-78675. EPSS is 0.18%. Act only if a listed version of GitPython before 3.1.59 fails is installed.
Which versions are affected?
Compare what you have installed with 3.1.30-1, 3.1.30-1+deb12u2, 3.1.36-1, 0 → 3.1.44-1+deb13u1, 0 → 3.1.61-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 25, 2026 · Trivy Vulnerability DB
Detected
GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include] directives. Attackers can craft a malicious .gitmodules file with include directives pointing to sensitive files; when repo.submodules is accessed, GitConfigParser raises MissingSectionHeaderError embedding the target fi
Oct 29, 2026 · Trivy Vulnerability DB
Fix available
python-git fixed in 3.1.44-1+deb13u1; python-git fixed in 3.1.61-1
Oct 29, 2026 · Trivy Vulnerability DB
Fix available
python-git fixed in 3.1.44-1+deb13u1
Oct 29, 2026 · Trivy Vulnerability DB
Fix available
python-git fixed in 3.1.61-1
Oct 29, 2026 · Trivy Vulnerability DB
Updated
GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include] directives. Attackers can craft a malicious .gitmodules file with include directives pointing to sensitive files; when repo.submodules is accessed, GitConfigParser raises MissingSectionHeaderError embedding the target fi
Sources
- CVE.orgVulnerability recordCVE-2026-78675
Official CVE identifier
cve.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-78675
GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include] directives. Attackers can craft a malicious .gitmodules file with include directives pointing to sen
osv.dev
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 29, 2026
- Trivy Vulnerability DBOct 29, 2026