Vulnerabilities

Vulnerability · CVE-2026-90628

Apache OpenOffice: Stack overflow in CFF hint handling

Published Nov 4, 2026 · catalog updated Nov 4, 2026 · Apache Software Foundation Apache OpenOffice

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-90628. EPSS is 0.23%. Act only if a listed version of Apache Software Foundation Apache OpenOffice is installed.

Gaps on this record

  • No version range is stored. A customer cannot check an installed version against this record.
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.23%
Remediation
Not established
Affected products
vendor Apache Software Foundation Apache OpenOffice

An uncontrolled memory access in the PDF export code of Apache OpenOffice versions through 4.1.16 allows a crafted CFF font to cause a stack overflow problem, causing program crash or memory corruption, or even running other code. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Apache Software Foundation Apache OpenOfficeversion unspecified

How to fix CVE-2026-90628

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-90628. EPSS is 0.23%. Act only if a listed version of Apache Software Foundation Apache OpenOffice is installed.

Which versions are affected?

Affected version ranges are not on this record. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-121: Stack-based Buffer Overflow. EPSS 0.23%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 4, 2026 · BSI CERT-Bund

    Detected

    CVE-2026-90628 is listed by Apache OpenOffice: Mehrere Schwachstellen.

  2. Nov 4, 2026 · CVE.org

    Updated

    An uncontrolled memory access in the PDF export code of Apache OpenOffice versions through 4.1.16 allows a crafted CFF font to cause a stack overflow problem, causing program crash or memory corruption, or even running other code. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

Sources

  • BSI CERT-BundGovernment advisoryCVE-2026-90628

    Apache OpenOffice: Mehrere Schwachstellen

    wid.cert-bund.de
  • CVE.orgVulnerability recordCVE-2026-90628

    An uncontrolled memory access in the PDF export code of Apache OpenOffice versions through 4.1.16 allows a crafted CFF font to cause a stack overflow problem, causing program crash or memory corruption, or even running other code. Users are recommended to upgrade to version 4.1.1

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-90628

    30-day exploitation probability 0.23%

    first.org
  • Openwall OSS SecurityThreat researchCVE-2026-90628

    Research mention from Openwall OSS Security. Not confirmation of exploitation.

    openwall.com
  • Tenable CVE DatabaseVulnerability recordCVE-2026-90628

    An uncontrolled memory access in the PDF export code of Apache OpenOffice versions through 4.1.16 allows a crafted CFF font to cause a stack overflow problem, causing program crash or memory corruption, or even running other code. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

    tenable.com

References

Freshness

Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Tenable CVE DatabaseNov 6, 2026
  • Openwall OSS SecurityNov 6, 2026
  • FIRST EPSSNov 5, 2026
  • CVE.orgNov 4, 2026
  • BSI CERT-BundNov 4, 2026