Security incident · CVE-2026-9086
Keycloak vulnerable to cross-site scripting (xss) via case-insensitive uri validation bypass
Published Aug 25, 2026 · catalog updated Oct 29, 2026 · Keycloak vulnerable to cross-site
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-9086. EPSS is 0.78%. Act only if a listed version of Keycloak vulnerable to cross-site is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Keycloak vulnerable to cross-site).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.78%
- Remediation
- Version ranges on file
- Affected products
- Bitnami keycloak · Maven org.keycloak:keycloak-services · maven org.keycloak · maven org.keycloak:keycloak-services
### Description A flaw was found in Keycloak. A remote attacker with administrative privileges, specifically those with permission or access to client registration endpoints, could bypass client Uniform Resource Identifier (URI) validation. This is achieved by registering a malicious client with a specially crafted redirect URI using a case-insensitive or scheme. This Cross-Site Scripting (XSS) vulnerability allows for arbitrary code execution in the Keycloak origin when a victim clicks the crafted link, such as in the logout flow or the Admin Console.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Bitnami keycloak26.4.0 → 26.4.13
- Maven org.keycloak:keycloak-services0 → 26.6.4
- maven org.keycloakversion unspecified
- maven org.keycloak:keycloak-services< 26.6.4
How to fix CVE-2026-9086
Upgrade
CVE-2026-9086 lists a fix boundary at 26.4.13. Compare the installed build with that boundary before you change production.
Version check
Affected < 26.6.4
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-9086. EPSS is 0.78%. Act only if a listed version of Keycloak vulnerable to cross-site is installed.
Which versions are affected?
Compare what you have installed with 26.4.0 → 26.4.13, 0 → 26.6.4, < 26.6.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS). EPSS 0.78%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 29, 2026 · GitHub Advisory Database
Detected
### Description A flaw was found in Keycloak. A remote attacker with administrative privileges, specifically those with permission or access to client registration endpoints, could bypass client Uniform Resource Identifier (URI) validation. This is achieved by registering a malicious client with a specially crafted redirect URI using a case-insensitive or scheme. This Cross-Site Scripting (XSS) vu
Oct 29, 2026 · GitHub Advisory Database
Fix available
org.keycloak:keycloak-services fixed in 26.6.4
Oct 29, 2026 · GitHub Advisory Database
Fix available
org.keycloak:keycloak-services fixed in 26.6.4
Oct 29, 2026 · GitHub Advisory Database
Fix available
keycloak fixed in 26.4.13
Oct 29, 2026 · GitHub Advisory Database
Fix available
keycloak fixed in 26.4.13
Oct 29, 2026 · GitHub Advisory Database
Updated
### Description A flaw was found in Keycloak. A remote attacker with administrative privileges, specifically those with permission or access to client registration endpoints, could bypass client Uniform Resource Identifier (URI) validation. This is achieved by registering a malicious client with a specially crafted redirect URI using a case-insensitive or scheme. This Cross-Site Scripting (XSS) vu
Sources
- CVE.orgVulnerability recordCVE-2026-9086
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-v3f7-2p4r-mwfw
Keycloak vulnerable to cross-site scripting (xss) via case-insensitive uri validation bypass
github.com - GitLab Advisory DatabasePackage advisoryCVE-2026-9086
A flaw was found in Keycloak. A remote attacker with administrative privileges, specifically those with manage-client permission or access to client registration endpoints, could bypass client Uniform Resource Identifier (URI) validation. This is achieved by registering a malicious client with a specially crafted redirect URI using a case-insensitive javascript: or data: scheme. This Cross-Site Sc
advisories.gitlab.com - OpenSSF OSV / OSV ScannerPackage advisoryBIT-keycloak-2026-9086
Keycloak: keycloak: cross-site scripting (xss) via case-insensitive uri validation bypass
osv.dev - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-v3f7-2p4r-mwfw
Keycloak vulnerable to cross-site scripting (xss) via case-insensitive uri validation bypass
osv.dev
References
Freshness
Last verified in this catalog Oct 30, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- GitLab Advisory DatabaseOct 31, 2026
- CVE.orgOct 30, 2026
- GitHub Advisory DatabaseOct 30, 2026
- OpenSSF OSV / OSV ScannerOct 30, 2026
- OpenSSF OSV / OSV ScannerOct 30, 2026