Security fix · CVE-2026-93587
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is s
Published Sep 18, 2026 · catalog updated Oct 26, 2026 · ImageMagick before 7.1.2-31 and
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-93587. EPSS is 0.12%. Act only if a listed version of ImageMagick before 7.1.2-31 and is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ImageMagick before 7.1.2-31 and).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Unknown—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.12%
- Remediation
- Advisory link
- Affected products
- Debian:12 imagemagick · Debian:13 imagemagick · Debian:14 imagemagick
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 imagemagick0 → 8:6.9.11.60+dfsg-1.6+deb12u14
- Debian:13 imagemagick8:7.1.1.43+dfsg1-1, 8:7.1.1.43+dfsg1-1+deb13u1, 8:7.1.1.43+dfsg1-1+deb13u10
- Debian:14 imagemagick0 → 8:7.1.2.31+dfsg1-1
How to fix CVE-2026-93587
Upgrade
CVE-2026-93587 lists a fix boundary at 8:6.9.11.60+dfsg-1.6+deb12u14. Compare the installed build with that boundary before you change production.
Version check
Fixed in 8:6.9.11.60+dfsg-1.6+deb12u14 · 4 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-93587. EPSS is 0.12%. Act only if a listed version of ImageMagick before 7.1.2-31 and is installed.
Which versions are affected?
Compare what you have installed with 0 → 8:6.9.11.60+dfsg-1.6+deb12u14, 8:7.1.1.43+dfsg1-1, 8:7.1.1.43+dfsg1-1+deb13u1, 8:7.1.1.43+dfsg1-1+deb13u10, 0 → 8:7.1.2.31+dfsg1-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.12%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 18, 2026 · OpenSSF OSV / OSV Scanner
Detected
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy
Oct 26, 2026 · OpenSSF OSV / OSV Scanner
Fix available
imagemagick fixed in 8:6.9.11.60+dfsg-1.6+deb12u14; imagemagick fixed in 8:7.1.2.31+dfsg1-1
Oct 26, 2026 · OpenSSF OSV / OSV Scanner
Fix available
imagemagick fixed in 8:6.9.11.60+dfsg-1.6+deb12u14
Oct 26, 2026 · OpenSSF OSV / OSV Scanner
Fix available
imagemagick fixed in 8:7.1.2.31+dfsg1-1
Oct 26, 2026 · OpenSSF OSV / OSV Scanner
Updated
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy
Sources
- CVE.orgVulnerability recordCVE-2026-93587
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-93587osv.dev
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 26, 2026
- OpenSSF OSV / OSV ScannerOct 26, 2026