Vulnerability · CVE-2026-93894
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL.
Published Sep 18, 2026 · catalog updated Oct 25, 2026 · In Vinyl Cache before
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-93894. EPSS is 0.36%. Act only if a listed version of In Vinyl Cache before is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Vinyl Cache before).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Unknown—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.36%
- Remediation
- Advisory link
- Affected products
- Debian:12 varnish · Debian:13 varnish · Debian:14 vinyl-cache
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a string that is long enough to fill the remaining workspace at the call site while staying under the different request size limits (http_req_size, http_req_hdr_len, etc.).
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 varnish7.1.1-1.1, 7.1.1-1.1+deb12u1, 7.1.1-1.2
- Debian:13 varnish0 → 7.7.0-3+deb13u2
- Debian:14 vinyl-cache9.0.0+20260429-2, 9.0.0+20260429-3, 9.0.1-1
How to fix CVE-2026-93894
Upgrade
CVE-2026-93894 lists a fix boundary at 7.7.0-3+deb13u2. Compare the installed build with that boundary before you change production.
Version check
Fixed in 7.7.0-3+deb13u2 · 6 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-93894. EPSS is 0.36%. Act only if a listed version of In Vinyl Cache before is installed.
Which versions are affected?
Compare what you have installed with 7.1.1-1.1, 7.1.1-1.1+deb12u1, 7.1.1-1.2, 0 → 7.7.0-3+deb13u2, 9.0.0+20260429-2, 9.0.0+20260429-3, 9.0.1-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.36%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 18, 2026 · Trivy Vulnerability DB
Detected
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a s
Oct 25, 2026 · Trivy Vulnerability DB
Fix available
varnish fixed in 7.7.0-3+deb13u2
Oct 25, 2026 · Trivy Vulnerability DB
Fix available
varnish fixed in 7.7.0-3+deb13u2
Oct 25, 2026 · Trivy Vulnerability DB
Updated
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a s
Sources
- CVE.orgVulnerability recordCVE-2026-93894
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-93894osv.dev
- Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2026-93894
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiti
osv.dev
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- OpenSSF OSV / OSV ScannerOct 25, 2026
- CVE.orgOct 25, 2026
- Trivy Vulnerability DBOct 25, 2026