Vulnerability · CVE-2026-96611
FFmpeg before 9.0 has a signed integer overflow in libavformat/mov.c.
Published Sep 23, 2026 · catalog updated Oct 29, 2026 · FFmpeg before 9.0 has
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-96611. EPSS is 0.11%. Act only if a listed version of FFmpeg before 9.0 has is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (FFmpeg before 9.0 has).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.11%
- Remediation
- Advisory link
- Affected products
- Debian:13 ffmpeg · Debian:14 ffmpeg
FFmpeg before 9.0 has a signed integer overflow in libavformat/mov.c. In mov_read_ispe(), uint32_t width/height values from a crafted HEIF ispe box are stored into signed int fields without bounds checking, allowing values exceeding INT_MAX to become negative. In read_image_grid(), accumulating these values causes signed integer overflow (undefined behavior per C17 section 6.5), which on x86 wraps to a small positive value, bypassing downstream validity checks.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:13 ffmpeg0 → 7:7.1.5-0+deb13u1
- Debian:14 ffmpeg0 → 7:8.1.2-1
How to fix CVE-2026-96611
Upgrade
CVE-2026-96611 lists a fix boundary at 7:7.1.5-0+deb13u1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 7:7.1.5-0+deb13u1 · 1 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-96611. EPSS is 0.11%. Act only if a listed version of FFmpeg before 9.0 has is installed.
Which versions are affected?
Compare what you have installed with 0 → 7:7.1.5-0+deb13u1, 0 → 7:8.1.2-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.11%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 23, 2026 · OpenSSF OSV / OSV Scanner
Detected
FFmpeg before 9.0 has a signed integer overflow in libavformat/mov.c. In mov_read_ispe(), uint32_t width/height values from a crafted HEIF ispe box are stored into signed int fields without bounds checking, allowing values exceeding INT_MAX to become negative. In read_image_grid(), accumulating these values causes signed integer overflow (undefined behavior per C17 section 6.5), which on x86 wraps
Sources
- CVE.orgVulnerability recordCVE-2026-96611
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-96611osv.dev
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 29, 2026
- OpenSSF OSV / OSV ScannerOct 29, 2026