Vulnerabilities

Vulnerability · CVE-2026-97313

Specific RPZ configurations and query patterns may result in an unexpected exit

Published Oct 21, 2026 · catalog updated Oct 23, 2026 · ISC BIND 9

Last checked Nov 1, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-97313. EPSS is 0.45%. Act only if a listed version of ISC BIND 9 is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.45%
Remediation
Advisory link
Affected products
Alpine:v3.22 bind · Alpine:v3.23 bind · Alpine:v3.24 bind · vendor ISC BIND 9

A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zones configured: one with the default setting of "recursive-only yes", and the other with "recursive-only no". This issue affects BIND 9 versions 9.16.0 through 9.18.50, 9.20.0 through 9.20.29, 9.21.0 through 9.21.26, 9.11.3-S1 through 9.18.50-S1, and 9.20.9-S1 through 9.20.29-S1.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • Alpine:v3.22 bind0 → 9.20.30-r0
  • Alpine:v3.23 bind0 → 9.20.30-r0
  • Alpine:v3.24 bind0 → 9.20.30-r0
  • vendor ISC BIND 9version unspecified

How to fix CVE-2026-97313

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-97313. EPSS is 0.45%. Act only if a listed version of ISC BIND 9 is installed.

Which versions are affected?

Compare what you have installed with 0 → 9.20.30-r0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-617. EPSS 0.45%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 21, 2026 · CVE.org

    Updated

    A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zones configured: one with the default setting of "recursive-only yes", and the other with "recursive-only no". This issue a

  2. Oct 21, 2026 · Canadian Centre for Cyber Security

    Detected

    CVE-2026-97313 is listed by ISC BIND security advisory (AV26-1072).

  3. Oct 23, 2026 · Trivy Vulnerability DB

    Fix available

    bind fixed in 9.20.30-r0; bind fixed in 9.20.30-r0; bind fixed in 9.20.30-r0

  4. Oct 23, 2026 · Trivy Vulnerability DB

    Fix available

    bind fixed in 9.20.30-r0

  5. Oct 23, 2026 · Trivy Vulnerability DB

    Updated

    A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zones configured: one with the default setting of "recursive-only yes", and the other with "recursive-only no". This issue a

Sources

  • BSI CERT-BundGovernment advisoryCVE-2026-97313

    Internet Systems Consortium BIND: Mehrere Schwachstellen

    wid.cert-bund.de
  • Canadian Centre for Cyber SecurityGovernment advisoryCVE-2026-97313

    Serial number: AV26-1072 Date: October 21, 2026 As of October 21, 2026, ISC is affected by a vulnerability in the following products: BIND 9 Versions 9.11.0 to 9.18.50 Versions 9.11.0 to 9.18.50 ◦ Versions 9.21.0 to 9.21.26 BIND Supported Preview Edition Versions 9.11.3-S1 to 9.1

    cyber.gc.ca
  • CVE.orgVulnerability recordCVE-2026-97313

    A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zone

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2026-97313

    30-day exploitation probability 0.45%

    first.org
  • Openwall OSS SecurityThreat researchCVE-2026-97313

    Research mention from Openwall OSS Security. Not confirmation of exploitation.

    openwall.com
  • Trivy Vulnerability DBPackage advisoryALPINE-CVE-2026-97313

    A recursive BIND server that receives a query with recursion desired (RD=1) followed by a non-recursive query (RD=0) may exit with an assertion failure, resulting in a denial of service. To be vulnerable, the BIND server must allow recursive queries and have at least two RPZ zone

    osv.dev

References

Freshness

Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • BSI CERT-BundOct 31, 2026
  • Canadian Centre for Cyber SecurityOct 28, 2026
  • Trivy Vulnerability DBOct 23, 2026
  • CVE.orgOct 23, 2026
  • FIRST EPSSOct 23, 2026
  • Openwall OSS SecurityOct 23, 2026