Vulnerabilities

Security fix · GHSA-44jh-23m7-hpcf

@better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL

Published Oct 27, 2026 · catalog updated Oct 27, 2026 · @better-auth/drizzle-adapter: Concurrent requests can

Last checked Oct 27, 2026, 12 days ago.

Open the advisory

Exploitation likelihood is not on this record for GHSA-44jh-23m7-hpcf. A missing EPSS score is not a low risk. Compare @better-auth/drizzle-adapter: Concurrent requests can with the linked advisory before you change production.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (@better-auth/drizzle-adapter: Concurrent requests can).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
  • EPSS is missing. A missing score is not a low risk.
Severity
Low3.7
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
Awaiting synchronization with FIRST
Remediation
Version ranges on file
Affected products
npm @better-auth/drizzle-adapter · npm @better-auth/kysely-adapter · npm better-auth

## Am I affected? You are affected if you use from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter versions above. You are not affected if you store rate-limit records in memory (the default) or in secondary storage. ## Summary Database-backed rate limiting on PostgreSQL can let a burst of concurrent requests go over the configured maximum. When many requests arrive at the same time, several of them can pass the limit check together. This weakens the rate limit on password sign-in, two-factor verification, one-time codes, password resets, and other rate-limited endpoints. ## Impact An attacker who sends many requests at once can make more attempts than the application allows. The issue does not bypass password or one-time-code validation. It does not directly compromise an account. The number of extra attempts is limited by the number of concurrent database connections, the number of application instances, and the rate-limit window. ## Patches is fixed in 1.7.0. Upgrade to 1.7.0 or later. The Drizzle fix is merged for the planned 1.7.7 release. That package is not available yet. Upgrade and the installed Drizzle adapter together when 1.7.7 is available. No database schema or public API migration is required. ## Workarounds - Store rate-limit records in secondary storage. - Use a custom rate-limit storage that checks and increments the counter in one atomic step. An atomic step cannot be interrupted by another request. - Enforce the intended limit at an upstream layer, such as a reverse proxy or gateway. In-memory storage also avoids this issue. However, each application instance keeps its own counter, so it may not enforce one shared limit in multi-instance or serverless deploy

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • npm @better-auth/drizzle-adapter>= 1.6.17, < 1.7.7
  • npm @better-auth/kysely-adapter>= 1.6.17, < 1.7.0
  • npm better-auth>= 1.6.17, < 1.7.7

How to fix GHSA-44jh-23m7-hpcf

  • Upgrade

    GHSA-44jh-23m7-hpcf lists a fix boundary at 1.7.7. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 1.7.7

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

Exploitation likelihood is not on this record for GHSA-44jh-23m7-hpcf. A missing EPSS score is not a low risk. Compare @better-auth/drizzle-adapter: Concurrent requests can with the linked advisory before you change production.

Which versions are affected?

Compare what you have installed with >= 1.6.17, < 1.7.7, >= 1.6.17, < 1.7.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-307: Improper Restriction of Excessive Authentication Attempts; CWE-362: Race Condition. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 27, 2026 · GitHub Advisory Database

    Detected

    ## Am I affected? You are affected if you use from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter version

  2. Oct 27, 2026 · GitHub Advisory Database

    Updated

    ## Am I affected? You are affected if you use from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database. All of these must be true: - Rate limiting is enabled. - Rate-limit records are stored in the database. - The database is PostgreSQL, used through one of the adapter version

Sources

References

Freshness

Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • GitHub Advisory DatabaseOct 27, 2026