Vulnerabilities

Vulnerability · GHSA-8xfc-pww7-3rm5

Privilege escalation through insufficient authorization in profile updates

Published Sep 16, 2026 · catalog updated Sep 16, 2026 · Privilege escalation through insufficient

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Open the advisory

Exploitation likelihood is not on this record for GHSA-8xfc-pww7-3rm5. A missing EPSS score is not a low risk. Compare Privilege escalation through insufficient with the linked advisory before you change production.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Privilege escalation through insufficient).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
  • EPSS is missing. A missing score is not a low risk.
Severity
High8.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
Awaiting synchronization with FIRST
Remediation
Version ranges on file
Affected products
composer shopware/core · composer shopware/platform

## Summary An authenticated Shopware Administration user with the permission could modify privileged properties of their own account through the profile update functionality. The affected authorization boundary did not sufficiently restrict nested writes, allowing a user without permission to promote their account to an administrator. ## Impact A user who can access their own profile ( ) could elevate their account to administrator status. This bypasses the assigned ACL role and may allow the user to create accounts, manage integrations, change system configuration, or install extensions. ## Affected versions - All Shopware versions before 6.6.10.25, including 6.5.x and earlier, as well as 6.6.0.0 through 6.6.10.24 - Shopware 6.7.0.0 through 6.7.14.0 ## Patches The issue is fixed in: - Shopware 6.6.10.25 - Shopware 6.7.14.1 The patch ensures that profile self-edit functionality cannot be used to modify administrator privileges or other protected account properties. ## Workarounds Until an update can be applied: - Restrict Administration access for untrusted users. - Remove the permission from roles that do not require profile self-editing. - Review existing administrator accounts and audit logs for unexpected privilege changes. ## Credits Thanks to @callghost for responsibly reporting this vulnerability.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • composer shopware/core<6.6.10.25
  • composer shopware/core>=6.7.0.0 <6.7.14.1
  • composer shopware/platform<6.6.10.25
  • composer shopware/platform>=6.7.0.0 <6.7.14.1

How to fix GHSA-8xfc-pww7-3rm5

  • Upgrade

    GHSA-8xfc-pww7-3rm5 lists a fix boundary at 6.6.10.25. Compare the installed build with that boundary before you change production.

  • Version check

    Affected <6.6.10.25

  • Advisory

    Open the inventory_github record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

Exploitation likelihood is not on this record for GHSA-8xfc-pww7-3rm5. A missing EPSS score is not a low risk. Compare Privilege escalation through insufficient with the linked advisory before you change production.

Which versions are affected?

Compare what you have installed with <6.6.10.25, >=6.7.0.0 <6.7.14.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 16, 2026 · Maintainer security tabs

    Detected

    ## Summary An authenticated Shopware Administration user with the permission could modify privileged properties of their own account through the profile update functionality. The affected authorization boundary did not sufficiently restrict nested writes, allowing a user without permission to promote their account to an administrator. ## Impact A user who can access their own profile ( ) could ele

Sources

  • Maintainer security tabsVendor advisoryGHSA-8xfc-pww7-3rm5

    ## Summary An authenticated Shopware Administration user with the permission could modify privileged properties of their own account through the profile update functionality. The affected authorization boundary did not sufficiently restrict nested writes, allowing a user without permission to promote their account to an administrator. ## Impact A user who can access their own profile ( ) could ele

    github.com

Freshness

Last verified in this catalog Sep 16, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Maintainer security tabsNov 2, 2026