Vulnerability · GHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Published Oct 22, 2026 · catalog updated Oct 23, 2026 · Brotli: Out-of-bounds write in
Last checked Oct 23, 2026, 13 days ago.
Open the advisory
Exploitation likelihood is not on this record for GHSA-9v8h-qqgm-4m35. A missing EPSS score is not a low risk. Compare Brotli: Out-of-bounds write in with the linked advisory before you change production.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Brotli: Out-of-bounds write in).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- EPSS is missing. A missing score is not a low risk.
- Severity
- Critical—
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- Awaiting synchronization with FIRST
- Remediation
- Advisory link
- Affected products
- PyPI brotli · PyPI brotlicffi
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI brotli1.0.3 → 1.2.1
- PyPI brotlicffi1.0.3 → 1.2.1.0
How to fix GHSA-9v8h-qqgm-4m35
Upgrade
GHSA-9v8h-qqgm-4m35 lists a fix boundary at 1.2.1. Compare the installed build with that boundary before you change production.
Version check
Seen in 1.0.3 → 1.2.1 · 1 other packages on the advisory
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
Exploitation likelihood is not on this record for GHSA-9v8h-qqgm-4m35. A missing EPSS score is not a low risk. Compare Brotli: Out-of-bounds write in with the linked advisory before you change production.
Which versions are affected?
Compare what you have installed with 1.0.3 → 1.2.1, 1.0.3 → 1.2.1.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-252: Unchecked Return Value. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 22, 2026 · PyPA Advisory Database
Detected
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli librarie
Oct 23, 2026 · PyPA Advisory Database
Fix available
brotli fixed in 1.2.1; brotlicffi fixed in 1.2.1.0
Oct 23, 2026 · PyPA Advisory Database
Fix available
brotli fixed in 1.2.1
Oct 23, 2026 · PyPA Advisory Database
Fix available
brotlicffi fixed in 1.2.1.0
Oct 23, 2026 · PyPA Advisory Database
Updated
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli librarie
Sources
- CIRCL Vulnerability LookupVulnerability recordGHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
vulnerability.circl.lu - PyPA Advisory DatabasePackage advisoryGHSA-9v8h-qqgm-4m35
Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
osv.dev
References
Freshness
Last verified in this catalog Oct 23, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CIRCL Vulnerability LookupOct 23, 2026
- PyPA Advisory DatabaseOct 23, 2026