Vulnerabilities

Security incident · GHSA-hrpp-p4fc-wwf8

ForwardAuth shares the auth-server connection pool, leaking NTLM/Negotiate-bound identity across clients

Published Oct 21, 2026 · catalog updated Oct 21, 2026 · ForwardAuth shares the auth-server

Last checked Nov 1, 2026. A connected source was read within the last 7 days.

Open the advisory

Exploitation likelihood is not on this record for GHSA-hrpp-p4fc-wwf8. A missing EPSS score is not a low risk. Compare ForwardAuth shares the auth-server with the linked advisory before you change production.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (ForwardAuth shares the auth-server).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
  • EPSS is missing. A missing score is not a low risk.
Severity
High—
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
Awaiting synchronization with FIRST
Remediation
Version ranges on file
Affected products
go github.com/traefik/traefik/v2 · go github.com/traefik/traefik/v3

## Summary There is a high severity authentication vulnerability in Traefik's ForwardAuth middleware when the authentication server uses a connection-bound scheme such as NTLM or SPNEGO/Kerberos "Negotiate" (for example IIS Windows Authentication). ForwardAuth sends its authentication subrequests through a connection pool shared by every client of the middleware, so an auth-server connection already authenticated by one user can be reused for the subrequest of an unrelated client. An unauthenticated client on a separate frontend connection can then receive a successful authentication response carrying the victim's identity, which Traefik forwards to the backend through , and access the backend as that user. In Traefik v3.7 the same applies to the external authentication requests issued for the Kubernetes Ingress NGINX provider's annotation. This is a distinct issue from GHSA-53qr-784g-cj35, GHSA-qqjf-53cj-pwvv, GHSA-cw35-4q88-3rmp and GHSA-qm9f-w54v-q2qh, which isolated connection-bound authentication on the backend proxy paths only; the fix applies the same per-frontend-connection isolation to the authentication server. Traefik v3.0 through v3.6 are end-of-life and are also affected; they will not receive a fix on their own line, and users on those versions must upgrade to v2.11.60 or v3.7.16. ## Patches - https://github.com/traefik/traefik/releases/tag/v2.11.60 - https://github.com/traefik/traefik/releases/tag/v3.7.16 ## For more information If you have any questions or comments about this advisory, please [open an issue](https://github.com/traefik/traefik/issues).

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • go github.com/traefik/traefik/v2<= v2.11.59
  • go github.com/traefik/traefik/v3>= v3.0.0, <= v3.7.15

How to fix GHSA-hrpp-p4fc-wwf8

  • Upgrade

    GHSA-hrpp-p4fc-wwf8 lists a fix boundary at v2.11.59. Compare the installed build with that boundary before you change production.

  • Version check

    Seen in <= v2.11.59 · 2 other packages on the advisory

  • Advisory

    Open the inventory_github record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

Exploitation likelihood is not on this record for GHSA-hrpp-p4fc-wwf8. A missing EPSS score is not a low risk. Compare ForwardAuth shares the auth-server with the linked advisory before you change production.

Which versions are affected?

Compare what you have installed with <= v2.11.59, >= v3.0.0, <= v3.7.15. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 21, 2026 · Maintainer security tabs

    Detected

    ## Summary There is a high severity authentication vulnerability in Traefik's ForwardAuth middleware when the authentication server uses a connection-bound scheme such as NTLM or SPNEGO/Kerberos "Negotiate" (for example IIS Windows Authentication). ForwardAuth sends its authentication subrequests through a connection pool shared by every client of the middleware, so an auth-server connection alrea

Sources

  • Maintainer security tabsVendor advisoryGHSA-hrpp-p4fc-wwf8

    ## Summary There is a high severity authentication vulnerability in Traefik's ForwardAuth middleware when the authentication server uses a connection-bound scheme such as NTLM or SPNEGO/Kerberos "Negotiate" (for example IIS Windows Authentication). ForwardAuth sends its authentication subrequests through a connection pool shared by every client of the middleware, so an auth-server connection alrea

    github.com

Freshness

Last verified in this catalog Oct 21, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Maintainer security tabsNov 1, 2026