Vulnerability · GHSA-p67w-3mq7-rw2g
Path traversal via writable media.fileExtension leads to remote code execution (single media:update privilege)
Published Aug 25, 2026 · catalog updated Aug 25, 2026 · Path traversal via writable
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Open the advisory
Exploitation likelihood is not on this record for GHSA-p67w-3mq7-rw2g. A missing EPSS score is not a low risk. Compare Path traversal via writable with the linked advisory before you change production.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Path traversal via writable).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- EPSS is missing. A missing score is not a low risk.
- Severity
- High8.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- Awaiting synchronization with FIRST
- Remediation
- Version ranges on file
- Affected products
- composer shopware/core · composer shopware/platform
## Impact Shopware did not sufficiently validate a media file extension during a media update. An authenticated Administration user with the privilege could use this to write files outside the intended media directory. In affected configurations, this could lead to arbitrary PHP code execution and full compromise of the shop. ## Affected versions - Shopware 6.7.1.0 through 6.7.13.0 ## Patches The issue is fixed in: - 6.7.13.1 We recommend updating to a patched version as soon as possible. ## Workarounds If an immediate update is not possible, restrict the privilege to fully trusted users and integrations. Review accounts and integrations that hold this privilege, and remove it where it is not required. ## Credits Thanks to [@HDWSec](https://github.com/HDWSec) for responsibly reporting this issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- composer shopware/core>= 6.7.1.0, <6.7.13.1
- composer shopware/platform>= 6.7.1.0, <6.7.13.1
How to fix GHSA-p67w-3mq7-rw2g
Upgrade
GHSA-p67w-3mq7-rw2g lists a fix boundary at 6.7.13.1. Compare the installed build with that boundary before you change production.
Version check
Affected <6.7.13.1
Advisory
Open the inventory_github record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
Exploitation likelihood is not on this record for GHSA-p67w-3mq7-rw2g. A missing EPSS score is not a low risk. Compare Path traversal via writable with the linked advisory before you change production.
Which versions are affected?
Compare what you have installed with >= 6.7.1.0, <6.7.13.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-22: Path Traversal; CWE-434: Unrestricted Upload of File with Dangerous Type; CWE-94: Code Injection. EPSS is not on this record yet. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 25, 2026 · Maintainer security tabs
Detected
## Impact Shopware did not sufficiently validate a media file extension during a media update. An authenticated Administration user with the privilege could use this to write files outside the intended media directory. In affected configurations, this could lead to arbitrary PHP code execution and full compromise of the shop. ## Affected versions - Shopware 6.7.1.0 through 6.7.13.0 ## Patches The
Sources
- Maintainer security tabsVendor advisoryGHSA-p67w-3mq7-rw2g
## Impact Shopware did not sufficiently validate a media file extension during a media update. An authenticated Administration user with the privilege could use this to write files outside the intended media directory. In affected configurations, this could lead to arbitrary PHP code execution and full compromise of the shop. ## Affected versions - Shopware 6.7.1.0 through 6.7.13.0 ## Patches The
github.com
Freshness
Last verified in this catalog Aug 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Maintainer security tabsNov 2, 2026