Vulnerability · CVE-2019-11323
HAProxy before 1.9.7 mishandles a reload with rotated keys, which triggers use of uninitialized, and very predictable, HMAC keys.
Published May 9, 2019 · catalog updated Jun 17, 2026 · HAProxy before 1.9.7 mishandles
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2019-11323. EPSS is 1.25%. Act only if a listed version of HAProxy before 1.9.7 mishandles is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (HAProxy before 1.9.7 mishandles).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-26081 · Medium
- CVE-2026-26080 · Low
- CVE-2026-55204 · High
- CVE-2026-55203 · Critical
- CVE-2026-33555 · Medium
- Severity
- Medium5.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.25%
- Remediation
- Version ranges on file
- Affected products
- cpe haproxy/haproxy
HAProxy before 1.9.7 mishandles a reload with rotated keys, which triggers use of uninitialized, and very predictable, HMAC keys. This is related to an include/types/ssl_sock.h error.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe haproxy/haproxy< 1.9.7
How to fix CVE-2019-11323
Upgrade
CVE-2019-11323 lists a fix boundary at 1.9.7. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.9.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2019-11323. EPSS is 1.25%. Act only if a listed version of HAProxy before 1.9.7 mishandles is installed.
Which versions are affected?
Compare what you have installed with < 1.9.7. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-327: Use of a Broken or Risky Cryptographic Algorithm; CWE-908: Use of Uninitialized Resource. EPSS 1.25%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
May 9, 2019 · Monitored products — high
Detected
HAProxy before 1.9.7 mishandles a reload with rotated keys, which triggers use of uninitialized, and very predictable, HMAC keys. This is related to an include/types/ssl_sock.h error.
Jun 17, 2026 · Monitored products — high
Updated
HAProxy before 1.9.7 mishandles a reload with rotated keys, which triggers use of uninitialized, and very predictable, HMAC keys. This is related to an include/types/ssl_sock.h error.
Sources
- CVE.orgVulnerability recordCVE-2019-11323
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2019-11323
HAProxy before 1.9.7 mishandles a reload with rotated keys, which triggers use of uninitialized, and very predictable, HMAC keys. This is related to an include/types/ssl_sock.h error.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026