Vulnerability · CVE-2019-14241
HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.
Published Jul 23, 2019 · catalog updated Jun 17, 2026 · HAProxy through 2.0.2 allows
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2019-14241 is not in CISA KEV. FIRST estimates a 70.24% chance of exploitation in the next 30 days. Check whether you run HAProxy through 2.0.2 allows.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (HAProxy through 2.0.2 allows).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-26081 · Medium
- CVE-2026-26080 · Low
- CVE-2026-55204 · High
- CVE-2026-55203 · Critical
- CVE-2026-33555 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 70.24%
- Remediation
- Version ranges on file
- Affected products
- cpe haproxy/haproxy
HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe haproxy/haproxy>= 1.4, <= 1.9.8
- cpe haproxy/haproxy>= 2.0.0, <= 2.0.2
How to fix CVE-2019-14241
Upgrade
CVE-2019-14241 lists a fix boundary at 1.9.8. Compare the installed build with that boundary before you change production.
Version check
Affected <= 1.9.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2019-14241 is not in CISA KEV. FIRST estimates a 70.24% chance of exploitation in the next 30 days. Check whether you run HAProxy through 2.0.2 allows.
Which versions are affected?
Compare what you have installed with >= 1.4, <= 1.9.8, >= 2.0.0, <= 2.0.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-835: Infinite Loop. EPSS 70.24%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 23, 2019 · Monitored products — high
Detected
HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.
Jun 17, 2026 · Monitored products — high
Updated
HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.
Sources
- CVE.orgVulnerability recordCVE-2019-14241
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2019-14241
HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — highNov 2, 2026