Vulnerabilities

Vulnerability · CVE-2025-46817

Lua library commands may lead to integer overflow and potential RCE

Published Oct 3, 2025 · catalog updated Oct 19, 2026 · Lua library commands may

Last checked Oct 31, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-46817. EPSS is 3.92%. Act only if a listed version of Lua library commands may is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Lua library commands may).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
3.92%
Remediation
Version ranges on file
Affected products
cpe redis/redis

### Impact An authenticated user may use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families. ### Credit The problem was reported by zhutyra

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe redis/redis< 6.2.20
  • cpe redis/redis< 7.2.11
  • cpe redis/redis< 7.4.6
  • cpe redis/redis< 8.0.4
  • cpe redis/redis< 8.2.2

How to fix CVE-2025-46817

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-46817. EPSS is 3.92%. Act only if a listed version of Lua library commands may is installed.

Which versions are affected?

Compare what you have installed with < 6.2.20, < 7.2.11, < 7.4.6, < 8.0.4, < 8.2.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-190: Integer Overflow. EPSS 3.92%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 3, 2025 · Monitored products — high

    Detected

    CVE-2025-46817 is listed by Redis is an open source, in-memory database that persists on disk..

  2. Oct 19, 2026 · Monitored products — high

    Updated

    CVE-2025-46817 is listed by Redis is an open source, in-memory database that persists on disk..

Sources

  • FIRST EPSSExploitation probabilityCVE-2025-46817

    30-day exploitation probability 3.92%

    first.org
  • Maintainer security tabsVendor advisoryGHSA-m8fj-85cg-7vhp

    ### Impact An authenticated user may use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to b

    github.com
  • Monitored products — highVendor advisoryCVE-2025-46817

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

    nvd.nist.gov

References

Freshness

Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 31, 2026
  • Maintainer security tabsOct 31, 2026
  • Monitored products — highOct 31, 2026