Vulnerability · CVE-2025-46818
Running Lua function as a different user
Published Oct 3, 2025 · catalog updated Oct 19, 2026 · Running Lua function as
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-46818. EPSS is 0.74%. Act only if a listed version of Running Lua function as is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Running Lua function as).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-23631 · Medium
- CVE-2026-25243 · High · known exploited
- CVE-2026-23479 · High
- CVE-2025-46817 · High
- CVE-2025-32023 · High
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.74%
- Remediation
- Version ranges on file
- Affected products
- cpe redis/redis
### Impact An authenticated user may use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user The problem exists in all versions of Redis with Lua scripting. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families. ### Credit The problem was reported by zhutyra
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redis/redis< 6.2.20
- cpe redis/redis< 7.2.11
- cpe redis/redis< 7.4.6
- cpe redis/redis< 8.0.4
- cpe redis/redis< 8.2.2
How to fix CVE-2025-46818
Upgrade
CVE-2025-46818 lists a fix boundary at 6.2.20. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.2.20
Advisory
Open the inventory_github record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-46818. EPSS is 0.74%. Act only if a listed version of Running Lua function as is installed.
Which versions are affected?
Compare what you have installed with < 6.2.20, < 7.2.11, < 7.4.6, < 8.0.4, < 8.2.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-94: Code Injection. EPSS 0.74%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 3, 2025 · Monitored products — high
Detected
CVE-2025-46818 is listed by Redis is an open source, in-memory database that persists on disk..
Oct 19, 2026 · Monitored products — high
Updated
CVE-2025-46818 is listed by Redis is an open source, in-memory database that persists on disk..
Sources
- FIRST EPSSExploitation probabilityCVE-2025-46818
30-day exploitation probability 0.74%
first.org - Maintainer security tabsVendor advisoryGHSA-qrv7-wcrx-q5jp
### Impact An authenticated user may use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user The problem exists in all versions of Redis with Lua scripting. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This
github.com - Monitored products — highVendor advisoryCVE-2025-46818
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 31, 2026
- Maintainer security tabsOct 31, 2026
- Monitored products — highOct 31, 2026