Vulnerability · CVE-2025-5302
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37.
Published Aug 25, 2025 · catalog updated Aug 25, 2025 · A denial of service
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-5302. EPSS is 0.29%. Act only if a listed version of A denial of service is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A denial of service).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-7707 · High
- CVE-2025-6209 · High
- CVE-2025-5472 · Medium
- CVE-2025-6210 · Medium
- CVE-2025-3046 · High
- Severity
- High8.6
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.29%
- Remediation
- Version ranges on file
- Affected products
- vendor run-llama run-llama/llama_index unspecified <0.12.38
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor run-llama run-llama/llama_index unspecified <0.12.38unspecified <0.12.38
How to fix CVE-2025-5302
Upgrade
CVE-2025-5302 lists a fix boundary at 0.12.38. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <0.12.38
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-5302. EPSS is 0.29%. Act only if a listed version of A denial of service is installed.
Which versions are affected?
Compare what you have installed with run-llama run-llama/llama_index unspecified <0.12.38 unspecified <0.12.38. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.29%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 25, 2025 · EUVD
Detected
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issu
Aug 25, 2025 · EUVD
Updated
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issu
Sources
- CVE.orgVulnerability recordCVE-2025-5302
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-5302
30-day exploitation probability 0.29%
first.org - EUVDVulnerability recordEUVD-2025-25708
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximu
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 22, 2026
- EUVDOct 22, 2026