Vulnerability · CVE-2025-6209
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the function in .
Published Jul 7, 2025 · catalog updated Jul 7, 2025 · A path traversal vulnerability
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-6209. EPSS is 0.62%. Act only if a listed version of A path traversal vulnerability is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A path traversal vulnerability).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-7707 · High
- CVE-2025-5302 · High
- CVE-2025-5472 · Medium
- CVE-2025-6210 · Medium
- CVE-2025-3046 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.62%
- Remediation
- Version ranges on file
- Affected products
- vendor run-llama run-llama/llama_index unspecified <0.12.41
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the function in . This vulnerability allows an attacker to manipulate the input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor run-llama run-llama/llama_index unspecified <0.12.41unspecified <0.12.41
How to fix CVE-2025-6209
Upgrade
CVE-2025-6209 lists a fix boundary at 0.12.41. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <0.12.41
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-6209. EPSS is 0.62%. Act only if a listed version of A path traversal vulnerability is installed.
Which versions are affected?
Compare what you have installed with run-llama run-llama/llama_index unspecified <0.12.41 unspecified <0.12.41. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.62%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 7, 2025 · EUVD
Detected
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the function in . This vulnerability allows an attacker to manipulate the input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files ou
Jul 7, 2025 · EUVD
Updated
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the function in . This vulnerability allows an attacker to manipulate the input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files ou
Sources
- CVE.orgVulnerability recordCVE-2025-6209
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-6209
30-day exploitation probability 0.62%
first.org - EUVDVulnerability recordEUVD-2025-20223
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the function in . This vulnerability allows an attacker to manipulate the input to read arbitrary files on the server, including sensitive system files. The issue
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026