Security fix · CVE-2025-62161
Youki is a container runtime written in Rust.
Published Nov 5, 2025 · catalog updated Nov 6, 2025 · Youki is a container
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-62161. EPSS is 0.26%. Act only if a listed version of Youki is a container is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Youki is a container).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-62596 · High
- CVE-2025-54867 · High
- Severity
- High7.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.26%
- Remediation
- Version ranges on file
- Affected products
- vendor youki-dev youki < 0.5.7
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor youki-dev youki < 0.5.7< 0.5.7
How to fix CVE-2025-62161
Upgrade
CVE-2025-62161 lists a fix boundary at 0.5.7. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.5.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-62161. EPSS is 0.26%. Act only if a listed version of Youki is a container is installed.
Which versions are affected?
Compare what you have installed with youki-dev youki < 0.5.7 < 0.5.7. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.26%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 5, 2025 · EUVD
Detected
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Nov 6, 2025 · EUVD
Updated
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Sources
- CVE.orgVulnerability recordCVE-2025-62161
Official CVE identifier
cve.org - EUVDVulnerability recordEUVD-2025-37939
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 25, 2026
- EUVDOct 25, 2026