Security fix · CVE-2025-64751
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar.
Published Nov 21, 2025 · catalog updated Nov 24, 2025 · OpenFGA is a high-performance
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-64751. EPSS is 0.31%. Act only if a listed version of OpenFGA is a high-performance is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (OpenFGA is a high-performance).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-40293 · Medium
- CVE-2026-33729 · Medium
- CVE-2025-55213 · Medium
- CVE-2025-48371 · Medium
- CVE-2025-46331 · Medium
- Severity
- Medium5.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.31%
- Remediation
- Version ranges on file
- Affected products
- vendor openfga openfga 1.4.0, < 1.11.1
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor openfga openfga 1.4.0, < 1.11.11.4.0, < 1.11.1
How to fix CVE-2025-64751
Upgrade
CVE-2025-64751 lists a fix boundary at 1.11.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.11.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-64751. EPSS is 0.31%. Act only if a listed version of OpenFGA is a high-performance is installed.
Which versions are affected?
Compare what you have installed with openfga openfga 1.4.0, < 1.11.1 1.4.0, < 1.11.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.31%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 21, 2025 · EUVD
Detected
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
Nov 24, 2025 · EUVD
Updated
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.
Sources
- CVE.orgVulnerability recordCVE-2025-64751
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-64751
30-day exploitation probability 0.31%
first.org - EUVDVulnerability recordEUVD-2025-198364
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcemen
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026