Security fix · CVE-2025-65961
Contao is an Open Source CMS.
Published Nov 25, 2025 · catalog updated Nov 25, 2025 · Contao is an Open
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-65961. EPSS is 0.18%. Act only if a listed version of Contao is an Open is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Contao is an Open).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-65960 · Medium
- CVE-2025-57759 · Medium
- CVE-2025-57758 · Medium
- CVE-2025-57757 · Medium
- CVE-2025-57756 · Medium
- Severity
- Low3.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.18%
- Remediation
- Version ranges on file
- Affected products
- vendor contao contao 4.0.0, < 4.13.57
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor contao contao 4.0.0, < 4.13.574.0.0, < 4.13.57
How to fix CVE-2025-65961
Upgrade
CVE-2025-65961 lists a fix boundary at 4.13.57. Compare the installed build with that boundary before you change production.
Version check
Affected < 4.13.57
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-65961. EPSS is 0.18%. Act only if a listed version of Contao is an Open is installed.
Which versions are affected?
Compare what you have installed with contao contao 4.0.0, < 4.13.57 4.0.0, < 4.13.57. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 25, 2025 · EUVD
Detected
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Nov 25, 2025 · EUVD
Updated
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves not using the affected templates or patch them manually.
Sources
- CVE.orgVulnerability recordCVE-2025-65961
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-65961
30-day exploitation probability 0.18%
first.org - EUVDVulnerability recordEUVD-2025-199631
Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, it is possible to inject code into the template output that will be executed in the browser in the front end and back end. This issue has been patched in versions 4.13.57, 5.3.42,
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026