Security fix · CVE-2025-66201
LibreChat is a ChatGPT clone with additional features.
Published Nov 29, 2025 · catalog updated Dec 1, 2025 · LibreChat
Last checked Oct 28, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66201. EPSS is 0.29%. Act only if a listed version of LibreChat is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-66452 · Medium
- CVE-2025-66451 · Medium
- CVE-2025-66450 · High
- CVE-2025-54868 · High
- Severity
- High8.6
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.29%
- Remediation
- Version ranges on file
- Affected products
- vendor danny-avila LibreChat < 0.8.1-rc2
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor danny-avila LibreChat < 0.8.1-rc2< 0.8.1-rc2
How to fix CVE-2025-66201
Upgrade
CVE-2025-66201 lists a fix boundary at 0.8.1-rc2. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.8.1-rc2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66201. EPSS is 0.29%. Act only if a listed version of LibreChat is installed.
Which versions are affected?
Compare what you have installed with danny-avila LibreChat < 0.8.1-rc2 < 0.8.1-rc2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.29%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Nov 29, 2025 · EUVD
Detected
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata
Dec 1, 2025 · EUVD
Updated
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata
Sources
- CVE.orgVulnerability recordCVE-2025-66201
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66201
30-day exploitation probability 0.29%
first.org - EUVDVulnerability recordEUVD-2025-199888
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authe
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 28, 2026
- CVE.orgOct 28, 2026
- EUVDOct 28, 2026