Security fix · CVE-2025-66451
LibreChat is a ChatGPT clone with additional features.
Published Dec 11, 2025 · catalog updated Dec 12, 2025 · LibreChat
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66451. EPSS is 0.33%. Act only if a listed version of LibreChat is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-66452 · Medium
- CVE-2025-66450 · High
- CVE-2025-66201 · High
- CVE-2025-54868 · High
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.33%
- Remediation
- Version ranges on file
- Affected products
- vendor danny-avila LibreChat < 0.8.1
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end system. The patchPromptGroup function passes req.body directly to updatePromptGroup() without filtering sensitive fields. This issue is fixed in version 0.8.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor danny-avila LibreChat < 0.8.1< 0.8.1
How to fix CVE-2025-66451
Upgrade
CVE-2025-66451 lists a fix boundary at 0.8.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.8.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66451. EPSS is 0.33%. Act only if a listed version of LibreChat is installed.
Which versions are affected?
Compare what you have installed with danny-avila LibreChat < 0.8.1 < 0.8.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 11, 2025 · EUVD
Detected
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end sy
Dec 12, 2025 · EUVD
Updated
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently validated for proper input, enabling users to modify prompts in a way that was not intended as part of the front end sy
Sources
- CVE.orgVulnerability recordCVE-2025-66451
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66451
30-day exploitation probability 0.33%
first.org - EUVDVulnerability recordEUVD-2025-202929
LibreChat is a ChatGPT clone with additional features. In versions 0.8.0 and below, when creating prompts, JSON requests are sent to define and modify the prompts via PATCH endpoint for prompt groups (/api/prompts/groups/:groupId). However, the request bodies are not sufficiently
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 27, 2026
- FIRST EPSSOct 27, 2026
- EUVDOct 27, 2026