Vulnerability · CVE-2025-66309
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages.
Published Dec 1, 2025 · catalog updated Dec 2, 2025 · This admin plugin for
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-66309. EPSS is 0.25%. Act only if a listed version of This admin plugin for is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (This admin plugin for).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-61454 · High
- CVE-2026-59193 · Medium
- CVE-2026-59190 · High
- CVE-2026-61456 · Medium
- CVE-2026-61455 · High
- Severity
- Medium6.2
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.25%
- Remediation
- Version ranges on file
- Affected products
- vendor getgrav grav < 1.11.0-beta.1
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] parameter. This vulnerability is fixed in 1.11.0-beta.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor getgrav grav < 1.11.0-beta.1< 1.11.0-beta.1
How to fix CVE-2025-66309
Upgrade
CVE-2025-66309 lists a fix boundary at 1.11.0-beta.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.11.0-beta.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-66309. EPSS is 0.25%. Act only if a listed version of This admin plugin for is installed.
Which versions are affected?
Compare what you have installed with getgrav grav < 1.11.0-beta.1 < 1.11.0-beta.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.25%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 1, 2025 · EUVD
Detected
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] paramet
Dec 2, 2025 · EUVD
Updated
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] paramet
Sources
- CVE.orgVulnerability recordCVE-2025-66309
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-66309
30-day exploitation probability 0.25%
first.org - EUVDVulnerability recordEUVD-2025-200101
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav ap
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 28, 2026
- EUVDOct 27, 2026