Vulnerability · CVE-2026-22252
LibreChat is a ChatGPT clone with additional features.
Published Jan 12, 2026 · catalog updated Jan 12, 2026 · LibreChat
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-22252. EPSS is 4.22%. Act only if a listed version of LibreChat is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-69222 · Critical
- CVE-2025-69221 · Medium
- CVE-2025-69220 · High
- CVE-2025-66452 · Medium
- CVE-2025-66451 · Medium
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 4.22%
- Remediation
- Version ranges on file
- Affected products
- vendor danny-avila LibreChat < v0.8.2-rc2
LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vulnerability is fixed in v0.8.2-rc2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor danny-avila LibreChat < v0.8.2-rc2< v0.8.2-rc2
How to fix CVE-2026-22252
Upgrade
CVE-2026-22252 lists a fix boundary at v0.8.2-rc2. Compare the installed build with that boundary before you change production.
Version check
Seen in < v0.8.2-rc2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-22252. EPSS is 4.22%. Act only if a listed version of LibreChat is installed.
Which versions are affected?
Compare what you have installed with danny-avila LibreChat < v0.8.2-rc2 < v0.8.2-rc2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 4.22%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 12, 2026 · EUVD
Detected
LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vulnerability is fixed in v0.8.2-rc2.
Jan 12, 2026 · EUVD
Updated
LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vulnerability is fixed in v0.8.2-rc2.
Sources
- CVE.orgVulnerability recordCVE-2026-22252
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-22252
30-day exploitation probability 4.22%
first.org - EUVDVulnerability recordEUVD-2026-2008
LibreChat is a ChatGPT clone with additional features. Prior to v0.8.2-rc2, LibreChat's MCP stdio transport accepts arbitrary commands without validation, allowing any authenticated user to execute shell commands as root inside the container through a single API request. This vul
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- CVE.orgOct 30, 2026
- EUVDOct 30, 2026