Security fix · CVE-2026-22704
HAX CMS helps manage microsite universe with PHP or NodeJs backends.
Published Jan 10, 2026 · catalog updated Jan 13, 2026 · HAX CMS helps manage
Last checked Nov 3, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-22704. EPSS is 1.03%. Act only if a listed version of HAX CMS helps manage is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (HAX CMS helps manage).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-54378 · High
- CVE-2025-54139 · Medium
- CVE-2025-54129 · Medium
- CVE-2025-54128 · High
- CVE-2025-54127 · Critical
- Severity
- High8.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.03%
- Remediation
- Version ranges on file
- Affected products
- vendor haxtheweb issues 11.0.6, < 25.0.0
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor haxtheweb issues 11.0.6, < 25.0.011.0.6, < 25.0.0
How to fix CVE-2026-22704
Upgrade
CVE-2026-22704 lists a fix boundary at 25.0.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 25.0.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-22704. EPSS is 1.03%. Act only if a listed version of HAX CMS helps manage is installed.
Which versions are affected?
Compare what you have installed with haxtheweb issues 11.0.6, < 25.0.0 11.0.6, < 25.0.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.03%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 10, 2026 · EUVD
Detected
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Jan 13, 2026 · EUVD
Updated
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
Sources
- CVE.orgVulnerability recordCVE-2026-22704
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2026-22704
30-day exploitation probability 1.03%
first.org - EUVDVulnerability recordEUVD-2026-1866
HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 3, 2026
- CVE.orgOct 30, 2026
- EUVDOct 30, 2026