Vulnerability · CVE-2026-94287
A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.
Published Sep 28, 2026 · catalog updated Nov 1, 2026 · OpenBSD OpenBSD
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-94287. EPSS is 0.13%. Act only if a listed version of OpenBSD OpenBSD is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-109090 · High
- CVE-2026-109089 · High
- CVE-2026-109088 · Medium
- CVE-2026-93536 · Medium
- CVE-2026-93524 · Medium
- Severity
- Medium5.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.13%
- Remediation
- Advisory link
- Affected products
- Debian:12 libxpm · Debian:13 libxpm · Debian:14 libxpm
A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 libxpm1:3.5.12-1.1, 1:3.5.12-1.1+deb12u1, 1:3.5.17-1
- Debian:13 libxpm1:3.5.17-1, 1:3.5.17-1+deb13u1, 1:3.5.19-1
- Debian:14 libxpm0 → 1:3.5.20-1
How to fix CVE-2026-94287
Upgrade
CVE-2026-94287 lists a fix boundary at 1:3.5.20-1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1:3.5.20-1 · 6 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-94287. EPSS is 0.13%. Act only if a listed version of OpenBSD OpenBSD is installed.
Which versions are affected?
Compare what you have installed with 1:3.5.12-1.1, 1:3.5.12-1.1+deb12u1, 1:3.5.17-1, 1:3.5.17-1, 1:3.5.17-1+deb13u1, 1:3.5.19-1, 0 → 1:3.5.20-1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.13%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 28, 2026 · OpenSSF OSV / OSV Scanner
Detected
A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.
Nov 1, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libxpm fixed in 1:3.5.20-1
Nov 1, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libxpm fixed in 1:3.5.20-1
Nov 1, 2026 · OpenSSF OSV / OSV Scanner
Updated
A denial of service via unsigned underflow in libXpm's write path in libXpm before 3.5.19 could be used by local attackers to cause unbounded CPU usage and memory exhaustion.
Sources
- CVE.orgVulnerability recordCVE-2026-94287
Official CVE identifier
cve.org - OpenBSD ErrataVendor advisoryCVE-2026-94287
CVE-2026-94287 is named on the public OpenBSD Errata page.
openbsd.org - OpenSSF OSV / OSV ScannerPackage advisoryDEBIAN-CVE-2026-94287osv.dev
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- OpenBSD ErrataNov 5, 2026
- CVE.orgNov 2, 2026
- OpenSSF OSV / OSV ScannerNov 1, 2026