Vulnerability · CVE-2024-31227
Denial-of-service due to malformed ACL selectors
Published Oct 7, 2024 · catalog updated Jun 16, 2026 · Denial-of-service due to malformed
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-31227. EPSS is 0.40%. Act only if a listed version of Denial-of-service due to malformed is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Denial-of-service due to malformed).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-23631 · Medium
- CVE-2026-25243 · High · known exploited
- CVE-2026-23479 · High
- CVE-2025-46818 · High
- CVE-2025-46817 · High
- Severity
- Medium4.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.40%
- Remediation
- Version ranges on file
- Affected products
- cpe redis/redis · n/a redis-server
### Impact An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. ### Patches The problem is fixed in Valkey 7.2.7 and 8.0.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redis/redis7.4.0
- cpe redis/redis< 7.2.6
- n/a redis-server>= 7.0.0
How to fix CVE-2024-31227
Upgrade
CVE-2024-31227 lists a fix boundary at 7.2.6. Compare the installed build with that boundary before you change production.
Version check
Affected < 7.2.6
Advisory
Open the inventory_github record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-31227. EPSS is 0.40%. Act only if a listed version of Denial-of-service due to malformed is installed.
Which versions are affected?
Compare what you have installed with 7.4.0, < 7.2.6, >= 7.0.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation. EPSS 0.40%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 7, 2024 · Monitored products — high
Detected
CVE-2024-31227 is listed by Redis is an open source, in-memory database that persists on disk..
Jun 16, 2026 · Monitored products — high
Updated
CVE-2024-31227 is listed by Redis is an open source, in-memory database that persists on disk..
Sources
- FIRST EPSSExploitation probabilityCVE-2024-31227
30-day exploitation probability 0.40%
first.org - Maintainer security tabsVendor advisoryGHSA-3864-2g29-c6pm
### Impact An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. ### Patches The problem is fixed in Valkey 7.2.7 and 8.0.1.
github.com - Maintainer security tabsVendor advisoryGHSA-38p4-26x2-vqhh
### Impact An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7.0.0 or newer. ### Patches The problem is fixed in Redis 7.2.6 and 7.4.1. ### Credit The problem was reported by Axel Mierczuk.
github.com - Monitored products — highVendor advisoryCVE-2024-31227
Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Maintainer security tabsNov 1, 2026
- FIRST EPSSOct 31, 2026
- Maintainer security tabsOct 31, 2026
- Monitored products — highOct 31, 2026