Vulnerability · CVE-2024-31449
Lua library commands may lead to stack overflow and potential RCE
Published Oct 6, 2024 · catalog updated Jun 16, 2026 · Lua library commands may
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-31449. EPSS is 4.46%. Act only if a listed version of Lua library commands may is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Lua library commands may).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-23631 · Medium
- CVE-2026-25243 · High · known exploited
- CVE-2026-23479 · High
- CVE-2025-46818 · High
- CVE-2025-46817 · High
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 4.46%
- Remediation
- Version ranges on file
- Affected products
- cpe redis/redis · n/a redis-server
### Impact An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Valkey with Lua scripting. ### Patches The problem is fixed in Valkey 7.2.7 and Valkey 8.0.1. ### Credit The problem was reported by ankki-zsyang, Shenzhen Ankki Technologies Co.Ltd.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe redis/redis7.4.0
- cpe redis/redis< 6.2.16
- cpe redis/redis< 7.2.6
- n/a redis-server>= 2.8.18
How to fix CVE-2024-31449
Upgrade
CVE-2024-31449 lists a fix boundary at 6.2.16. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.2.16
Advisory
Open the inventory_github record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-31449. EPSS is 4.46%. Act only if a listed version of Lua library commands may is installed.
Which versions are affected?
Compare what you have installed with 7.4.0, < 6.2.16, < 7.2.6, >= 2.8.18. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-121: Stack-based Buffer Overflow; CWE-20: Improper Input Validation. EPSS 4.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 7, 2024 · Monitored products — high
Detected
CVE-2024-31449 is listed by Redis is an open source, in-memory database that persists on disk..
Jun 16, 2026 · Monitored products — high
Updated
CVE-2024-31449 is listed by Redis is an open source, in-memory database that persists on disk..
Sources
- FIRST EPSSExploitation probabilityCVE-2024-31449
30-day exploitation probability 4.46%
first.org - Maintainer security tabsVendor advisoryGHSA-cjwh-fcpr-v5r7
### Impact An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Valkey with Lua scripting. ### Patches The problem is fixed in Valkey 7.2.7 and Valkey 8.0.1. ### Credit The problem was reported by ankki-zsyang, Shenzhen Ankki Technologies Co.Ltd.
github.com - Maintainer security tabsVendor advisoryGHSA-whxg-wx83-85p5
### Impact An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. ### Patches The problem is fixed in Redis 6.2.16, 7.2.6, 7.4.1. ### Credit The problem was reported by ankki-zsyang, Shenzhen Ankki Technologies Co.Ltd.
github.com - Monitored products — highVendor advisoryCVE-2024-31449
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Maintainer security tabsNov 1, 2026
- FIRST EPSSOct 31, 2026
- Maintainer security tabsOct 31, 2026
- Monitored products — highOct 31, 2026