Vulnerability · CVE-2024-46981
Lua library commands may lead to remote code execution
Published Jan 6, 2025 · catalog updated Jun 16, 2026 · Lua library commands may
Last checked Oct 31, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-46981. EPSS is 8.18%. Act only if a listed version of Lua library commands may is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Lua library commands may).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-23631 · Medium
- CVE-2026-25243 · High · known exploited
- CVE-2026-23479 · High
- CVE-2025-46818 · High
- CVE-2025-46817 · High
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 8.18%
- Remediation
- Version ranges on file
- Affected products
- cpe debian/debian linux · cpe redis/redis
### Impact An authenticated user may use a specially crafted Lua script to manipulate the garbage collector and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. ### Patches The problem is fixed in Redis 6.2.x, 7.2.x and 7.4.x. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands. ### Credit The problem was reported by p33zy working with Trend Micro Zero Day Initiative
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe debian/debian linux11.0
- cpe redis/redis< 6.2.17
- cpe redis/redis< 7.2.7
- cpe redis/redis< 7.4.2
How to fix CVE-2024-46981
Upgrade
CVE-2024-46981 lists a fix boundary at 6.2.17. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.2.17
Advisory
Open the inventory_github record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-46981. EPSS is 8.18%. Act only if a listed version of Lua library commands may is installed.
Which versions are affected?
Compare what you have installed with debian/debian linux 11.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-416: Use After Free. EPSS 8.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jan 6, 2025 · Monitored products — high
Detected
CVE-2024-46981 is listed by Redis is an open source, in-memory database that persists on disk..
Jun 16, 2026 · Monitored products — high
Updated
CVE-2024-46981 is listed by Redis is an open source, in-memory database that persists on disk..
Sources
- FIRST EPSSExploitation probabilityCVE-2024-46981
30-day exploitation probability 8.18%
first.org - Maintainer security tabsVendor advisoryGHSA-39h2-x6c4-6w4c
### Impact An authenticated user may use a specially crafted Lua script to manipulate the garbage collector and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. ### Patches The problem is fixed in Redis 6.2.x, 7.2.x and 7.4.x. ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to
github.com - Monitored products — highVendor advisoryCVE-2024-46981
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to manipulate the garbage collector and potentially lead to remote code execution. The problem is fixed in 7.4.2, 7.2.7, and 6.2.17. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua script
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 31, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 31, 2026
- Maintainer security tabsOct 31, 2026
- Monitored products — highOct 31, 2026