Vulnerabilities

Vulnerability · CVE-2025-67504

WBCE CMS is a content management system.

Published Dec 9, 2025 · catalog updated Dec 9, 2025 · WBCE_CMS

Last checked Oct 28, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-67504. EPSS is 0.52%. Act only if a listed version of WBCE_CMS is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.52%
Remediation
Version ranges on file
Affected products
vendor wbce WBCE_CMS < 1.6.5

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor wbce WBCE_CMS < 1.6.5< 1.6.5

How to fix CVE-2025-67504

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-67504. EPSS is 0.52%. Act only if a listed version of WBCE_CMS is installed.

Which versions are affected?

Compare what you have installed with wbce WBCE_CMS < 1.6.5 < 1.6.5. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.52%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 9, 2025 · EUVD

    Detected

    WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is

  2. Dec 9, 2025 · EUVD

    Updated

    WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is

Sources

  • CVE.orgVulnerability recordCVE-2025-67504

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-67504

    30-day exploitation probability 0.52%

    first.org
  • EUVDVulnerability recordEUVD-2025-201876

    WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account c

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 28, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 27, 2026