Vulnerabilities

Vulnerability · CVE-2026-104711

Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts.

Published Oct 5, 2026 · catalog updated Oct 8, 2026 · Improper neutralization of special

Last checked Nov 8, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2026-104711. EPSS is 1.39%. Act only if a listed version of Improper neutralization of special is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Improper neutralization of special).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.8
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.39%
Remediation
Version ranges on file
Affected products
cpe apache/struts

Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe apache/struts< 6.12.0
  • cpe apache/struts< 7.4.0
  • cpe apache/struts>= 2.0.0, <= 2.3.37
  • cpe apache/struts>= 2.5.0, <= 2.5.33

How to fix CVE-2026-104711

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2026-104711. EPSS is 1.39%. Act only if a listed version of Improper neutralization of special is installed.

Which versions are affected?

Compare what you have installed with < 6.12.0, < 7.4.0, >= 2.0.0, <= 2.3.37, >= 2.5.0, <= 2.5.33. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-917: Expression Language Injection. EPSS 1.39%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 5, 2026 · Monitored products — high

    Detected

    Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default

  2. Oct 8, 2026 · Monitored products — high

    Updated

    Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default

Sources

  • FIRST EPSSExploitation probabilityCVE-2026-104711

    30-day exploitation probability 1.39%

    first.org
  • Monitored products — highVendor advisoryCVE-2026-104711

    Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 8, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 8, 2026
  • Monitored products — highNov 8, 2026