Vulnerability · CVE-2026-104713
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin.
Published Oct 5, 2026 · catalog updated Oct 8, 2026 · Allocation of resources without
Last checked Nov 8, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-104713. EPSS is 0.56%. Act only if a listed version of Allocation of resources without is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Allocation of resources without).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-104714 · High
- CVE-2026-104712 · High
- CVE-2026-104711 · Critical
- CVE-2026-73635 · High
- CVE-2026-73634 · High
- Severity
- Medium6.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.56%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/struts
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not use the REST plugin are not affected. This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0. Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/struts< 6.12.0
- cpe apache/struts< 7.4.0
- cpe apache/struts>= 2.1.8, <= 2.3.37
- cpe apache/struts>= 2.5.0, <= 2.5.33
How to fix CVE-2026-104713
Upgrade
CVE-2026-104713 lists a fix boundary at 6.12.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.12.0
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-104713. EPSS is 0.56%. Act only if a listed version of Allocation of resources without is installed.
Which versions are affected?
Compare what you have installed with < 6.12.0, < 7.4.0, >= 2.1.8, <= 2.3.37, >= 2.5.0, <= 2.5.33. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.56%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Oct 5, 2026 · Monitored products — high
Detected
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not us
Oct 8, 2026 · Monitored products — high
Updated
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not us
Sources
- FIRST EPSSExploitation probabilityCVE-2026-104713
30-day exploitation probability 0.56%
first.org - Monitored products — highVendor advisoryCVE-2026-104713
Allocation of resources without limits or throttling vulnerability in the Apache Struts REST plugin. A request body is read into memory without any bound on how much will be accepted, so a single request can cause the server to allocate memory in proportion to its size, exhausting the Java heap and denying service to other users. No additional setting has to be enabled. Applications that do not us
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 8, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 8, 2026
- Monitored products — highNov 8, 2026