Vulnerability · CVE-2026-73634
Uncontrolled resource consumption vulnerability in Apache Struts.
Published Aug 15, 2026 · catalog updated Aug 18, 2026 · Uncontrolled resource consumption vulnerability
Last checked Nov 8, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2026-73634. EPSS is 0.43%. Act only if a listed version of Uncontrolled resource consumption vulnerability is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Uncontrolled resource consumption vulnerability).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-104714 · High
- CVE-2026-104713 · Medium
- CVE-2026-104712 · High
- CVE-2026-104711 · Critical
- CVE-2026-73635 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/struts
Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution maps no such endpoint by default; applications that do not collect violation reports are not affected. This issue affects Apache Struts: from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/struts< 6.11.0
- cpe apache/struts< 7.3.0
How to fix CVE-2026-73634
Upgrade
CVE-2026-73634 lists a fix boundary at 6.11.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.11.0
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2026-73634. EPSS is 0.43%. Act only if a listed version of Uncontrolled resource consumption vulnerability is installed.
Which versions are affected?
Compare what you have installed with < 6.11.0, < 7.3.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-400: Uncontrolled Resource Consumption. EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 15, 2026 · Monitored products — high
Detected
Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution
Aug 18, 2026 · Monitored products — high
Updated
Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution
Sources
- FIRST EPSSExploitation probabilityCVE-2026-73634
30-day exploitation probability 0.43%
first.org - Monitored products — highVendor advisoryCVE-2026-73634
Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 8, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 8, 2026
- Monitored products — highNov 8, 2026